car

100

Asked by Mar 18, 2014 at 05:37 PM about the 2004 Vauxhall Zafira

Question type: General

my zafira 1.8 auto  revs up fine when stud but wen under load at 3500rpm its goes in to
limp mode code read it miss fire on number one if i clear it it starts fine ticks over fine i
can rev it as soon as i drive off and get to 3500rpm it goes back to limp mode just wonder
if a coil pack can work fine on tick over but break down when under load.

1 Answer

880

Check your plugs when you remove the coils, they might be worn or fouled.

Your answer:

Vauxhall Zafira experts

  • #1
    hummerh1alphame
    Reputation
    20
  • #2
    Stevie Reynoldz
    Reputation
    10
  • #2
    AmateurCarTech
    Reputation
    10
View all

Related models for sale

Volkswagen Touran for sale
25 Great deals out of 473 listings starting at £1,490
Ford Galaxy for sale
35 Great deals out of 511 listings starting at £1,290
Vauxhall Meriva for sale
85 Great deals out of 1,114 listings starting at £889
Vauxhall Astra for sale
477 Great deals out of 6,284 listings starting at £250
Ford Focus for sale
630 Great deals out of 9,778 listings starting at £395
Vauxhall Corsa for sale
570 Great deals out of 8,860 listings starting at £690
Renault Scenic for sale
31 Great deals out of 489 listings starting at £495
Toyota Verso for sale
26 Great deals out of 375 listings starting at £1,000
Vauxhall Vectra for sale
7 Great deals out of 226 listings starting at £790

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use. Content will be removed if CarGurus becomes aware that it violates our policies.