car

90

Asked by Mar 18, 2014 at 05:37 PM about the 2004 Vauxhall Zafira

Question type: General

my zafira 1.8 auto  revs up fine when stud but wen under load at 3500rpm its goes in to
limp mode code read it miss fire on number one if i clear it it starts fine ticks over fine i
can rev it as soon as i drive off and get to 3500rpm it goes back to limp mode just wonder
if a coil pack can work fine on tick over but break down when under load.

1 Answer

640

Check your plugs when you remove the coils, they might be worn or fouled.

Your Answer

Add photo

Related Questions

Search Vauxhall Zafira Questions

Vauxhall Zafira Experts

#1 hummerh1alphame
hummerh1alphame
Reputation 20
#2 Stevie Reynoldz
Stevie Reynoldz
Reputation 10
#2 Full_of_Regrets
Full_of_Regrets
Reputation 10
View All

Related Models For Sale

Used Ford Galaxy
37 Great Deals out of 518 listings starting at £1,000
Used Volkswagen Touran
45 Great Deals out of 665 listings starting at £1,295
Used Vauxhall Astra
509 Great Deals out of 6,834 listings starting at £390
Used Vauxhall Meriva
82 Great Deals out of 1,404 listings starting at £700
Used Toyota Verso
24 Great Deals out of 391 listings starting at £990
Used Vauxhall Corsa
447 Great Deals out of 8,572 listings starting at £450
Used Volkswagen Sharan
15 Great Deals out of 296 listings starting at £8,790
Used Renault Grand Scenic
23 Great Deals out of 342 listings starting at £1,195

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.