did ask but try again.........polo BAH engine, everything new, nice when cold but as soon as the temp pick up it struckles to rev up, plz help

70

Asked by Jun 08, 2015 at 09:39 AM about the 2005 Volkswagen Polo

Question type: Maintenance & Repair

1 Answer

70

got the problem, bad speed sensor

1 of 1 people found this helpful.

Your Answer

Add photo

Related Questions

Search Volkswagen Polo Questions

Volkswagen Polo Experts

#1 DavidH25
DavidH25
Reputation 250
#2 migration_judge_roy
migration_judge_roy
Reputation 180
#3 Deathjam4
Deathjam4
Reputation 130
View All

Related Models For Sale

Used Volkswagen Golf
460 Great Deals out of 7,815 listings starting at £600
Used Ford Fiesta
585 Great Deals out of 11,388 listings starting at £425
Used Vauxhall Corsa
449 Great Deals out of 7,936 listings starting at £390
Used Toyota Yaris
126 Great Deals out of 2,468 listings starting at £400
Used Seat Ibiza
130 Great Deals out of 1,846 listings starting at £700
Used Renault Clio
173 Great Deals out of 2,978 listings starting at £500
Used Vauxhall Astra
424 Great Deals out of 6,929 listings starting at £390
Used BMW 1 Series
255 Great Deals out of 4,360 listings starting at £1,890
Used Audi A3
284 Great Deals out of 4,055 listings starting at £1,295
Used Ford Focus
626 Great Deals out of 9,478 listings starting at £495
Used MINI Mini
236 Great Deals out of 5,097 listings starting at £890
Used Skoda Fabia
106 Great Deals out of 1,754 listings starting at £600
Used Honda Civic
180 Great Deals out of 2,686 listings starting at £649

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.