did ask but try again.........polo BAH engine, everything new, nice when cold but as soon as the temp pick up it struckles to rev up, plz help

70

Asked by Jun 08, 2015 at 09:39 AM about the 2005 Volkswagen Polo

Question type: Maintenance & Repair

1 Answer

70

got the problem, bad speed sensor

1 of 1 people found this helpful.

Your Answer

Add photo

Related Questions

Search Volkswagen Polo Questions

Volkswagen Polo Experts

#1 DavidH25
DavidH25
Reputation 240
#2 migration_judge_roy
migration_judge_roy
Reputation 170
#3 Deathjam4
Deathjam4
Reputation 130
View All

Related Models For Sale

Used Volkswagen Golf
505 Great Deals out of 7,240 listings starting at £995
Used Ford Fiesta
634 Great Deals out of 11,463 listings starting at £425
Used Vauxhall Corsa
435 Great Deals out of 8,537 listings starting at £495
Used Toyota Yaris
158 Great Deals out of 2,318 listings starting at £400
Used Seat Ibiza
117 Great Deals out of 1,999 listings starting at £750
Used Renault Clio
158 Great Deals out of 3,197 listings starting at £395
Used BMW 1 Series
274 Great Deals out of 4,235 listings starting at £1,595
Used Vauxhall Astra
506 Great Deals out of 6,821 listings starting at £390
Used Audi A3
283 Great Deals out of 4,118 listings starting at £1,450
Used Ford Focus
632 Great Deals out of 9,647 listings starting at £495
Used MINI Mini
235 Great Deals out of 4,500 listings starting at £895
Used Skoda Fabia
89 Great Deals out of 1,652 listings starting at £600

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.